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11Introduction

In this chapter...

“Configuration” on page 2
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�You cannot use Accounting 
Link with MaxExchange 
Remote Workstations.

Maximizer Accounting Link for Microsoft Dynamics™ GP enables you 
to create quotes, invoices, and purchase orders from within 
Maximizer, while simultaneously creating them in the Dynamics GP 
database. Entering Dynamics GP transactions through Maximizer also 
logs a note for the related Address Book entry.

For a current list of supported Dynamics GP versions, refer to the 
Maximizer website at www.maximizer.com. 

This guide explains how to install, configure, and operate 
Accounting Link.

Configuration
In a typical client/server configuration, the client connects to the 
Dynamics GP database on the SQL server. In this environment, 
multiple Maximizer machines can connect to the same Dynamics GP 
server. This configuration requires Dynamics GP to be installed on the 
Dynamics GP application machine. The Installation chapter explains 
how to install this software. 
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Accounting Link

In this chapter...

“Pre-Installation Steps for Accounting Link” on page 4

“Installing Accounting Link” on page 5
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Pre-Installation Steps for Accounting Link
During the installation of Accounting Link, the installer prompts for 
login information to the Microsoft Dynamics GP database. This 
information is used to verify a connection to the SQL server hosting 
the Microsoft Dynamics GP database. The first time Maximizer is 
launched after the installation of Accounting Link, Maximizer will 
prompt again for this information. 

The user account you specify for the eConnect portion of the 
installation must be a Domain user account that is a part of the 
DynGroup role for the Microsoft Dynamics GP Company and 
DYNAMICS database. This user account must be a COM+ user 
account. 

In addition, Distributed Transaction Coordinator (DTC) and Microsoft 
Message Queueing (MSMQ) must be enabled on the Microsoft 
Dynamics GP server and the workstation on which Accounting Link is 
being installed. Note that you can install eConnect before MSMQ, 
but the eConnect services will not start until MSMQ is available. Note 
also that DTC requires configuration.

You must set up a functional currency for the Microsoft Dynamics GP 
company that Accounting Link will be connecting to, even if 
multicurrency is not being used. For information on setting up a 
functional currency, refer to the Microsoft Dynamics GP 
documentation.

For complete instructions on enabling these services and configuring 
DTC for eConnect, please refer to your eConnect Install 
Administrator’s Guide (eConnectInstallAdminGuide.PDF).
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Installing Accounting Link
Maximizer must be installed before you can install Accounting Link. 
Install Accounting Link software on all computers that will connect to 
Dynamics GP through Maximizer.

➤ To install Maximizer Accounting Link for Microsoft 
Dynamics GP

� Insert the Maximizer Accounting Link for Microsoft Dynamics GP 
CD into the CD-ROM drive.

�If the setup doesn’t start 
automatically, you can start it 
manually by running 
autorun.exe from the CD.

The installation wizard runs automatically.

� Select Install Accounting Link for Microsoft Dynamics GP.

The InstallShield Wizard starts.

� Click Next.

� Read the License Agreement, and select I accept the terms of 
the license agreement, and click Next.

� Enter your Product Serial Number, First Name, Last Name, 
and Company, and click Next.

� Read the Release Notes, and click Next.
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� Enter the Windows login credentials for the domain user to 
connect through eConnect to the Dynamics GP server (SQL 
server).

	 Enter the SQL login credentials for Accounting Link to connect to 
the Dynamics GP server.
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 Click Next to begin the installation.

The wizard displays an installation progress indicator. 
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Accounting Link for

Remote Operation

In this chapter...

“Setting Accounting Link Preferences” on page 10
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Setting Accounting Link Preferences
After you have installed Accounting Link, the first time you start 
Maximizer, the Integration Setup dialog box appears. Enter the 
information as described in the following steps. 

� In Maximizer, select File > Preferences, and click the 
Accounting Setup button.

� Select the Enable Microsoft Dynamics GP Integration 
checkbox. 

� Select the SQL server that is hosting the Dynamics GP database.

� Select the type of Authentication you are using.

� Enter the User name and password for the selected SQL server 
and click the Connect button. This connects to the SQL server 
and a list of available databases appears in the Database name 
field.

� Once you have successfully connected to the SQL server, select 
the database you are using with Accounting Link from the 
Database name field and click the Initialize button. Clicking 
this button verifies you have chosen a valid Dynamics GP 
database for integration with Accounting Link. 

The next time you start Maximizer, Accounting Link will connect 
to the selected Dynamics GP database. If you modify the 
integration information, restart Maximizer to initialize the 
changes. 

For instructions on using Accounting Link, refer to “Using 
Accounting Link” on page 15.
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Rights to Maximizer

Users

In this chapter...

“Enabling Accounting Module Access” on page 12

“Adding Users to the Accounting Security Group” on page 13

“Granting Accounting Permissions” on page 14
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Enabling Accounting Module Access
After installing Accounting Link licenses, you can set user access in 
the Module Login list in user properties. Users must have Accounting 
module access enabled before they can use Accounting Link in 
Maximizer.

➤ To enable accounting module access for a user

� Log into the Address Book in Administrator.

� Select File > Users.

� Select the user to grant accounting privileges, and click 
Properties.

� In the Module Login section of the General tab, set the 
Accounting module to Enabled.

� Click OK.

Repeat this procedure for all users who will be using Accounting 
Link.
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Adding Users to the Accounting Security Group

�For more information about 
user and group security, refer 
to your Maximizer 
Administrator documentation.

The Accounting security group enables users to restrict accounting 
transaction notes to members of this group. If an Accounting Link 
user is not a member of the Accounting security group, notes for any 
accounting transactions created by that user are Public. However, 
notes for transactions created by members of the Accounting group 
are restricted to members of that group.

�You can add multiple users to 
the security group by selecting 
File > Security Groups and 
Teams, selecting the 
Accounting security group and 
clicking Properties, clicking the 
Members tab, and then adding 
users to the group.

➤ To add a user to the Accounting security group

� Log into the Address Book in Administrator.

� Select File > Users.

� Select the user to grant accounting privileges, and click 
Properties.

� Click the Groups/Teams tab.

� Select the Accounting security group from the Available 
groups and teams list, and click Add.

The Accounting security group now appears in the Member of 
list.

� Click OK.

Repeat this procedure for all users who will be using Accounting 
Link.
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Granting Accounting Permissions
�Delete permissions are not 

available for accounting 
transactions.

Accounting permissions control whether users can read, insert, or 
modify accounting transactions. 

�For more information about 
user and group security, refer 
to your Maximizer 
Administrator documentation.

➤ To grant accounting permissions to a user

� Log into the Address Book in Administrator.

� Select File > Users.

� Select the user to grant accounting privileges, and click 
Properties.

� Click the Access Rights tab.

� Click the Modify User Access Settings button.

�The Delete permission for 
Accounting is disabled 
because Accounting Link 
cannot delete transactions 
from the accounting database.

� In the Permissions group, select any of the Accounting rights, 
as appropriate for the user, and click OK.

� Click OK to close the user properties dialog box.

Repeat this procedure for all users who will be using Accounting 
Link.
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In this chapter...

“Connecting to Dynamics GP with Maximizer” on page 16

“Linking Address Book Entries” on page 16

“Creating Invoices, Quotes, and Purchase Orders” on page 19

“Viewing Invoices, Quotes, and Purchase Orders” on page 24

“Viewing Accounting Details about a Customer or Vendor” on page 25
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Connecting to Dynamics GP with Maximizer
It’s important that Accounting Link and Maximizer are configured 
correctly before proceeding. Otherwise, the procedures outlined in 
this chapter will not work properly. 

Linking Address Book Entries
�If you re-link a Company file to 

a different Address Book, all of 
your Address Book entries 
must also be re-linked.

Before you can create any invoices, quotes, or purchase orders in 
Maximizer, you must create a link between each Maximizer Address 
Book entry and Microsoft Dynamics GP customer or vendor. 

• If the customer or vendor record does not exist in the Dynamics 
GP database, you can create the Accounting Link record from 
Maximizer using an existing Maximizer Address Book entry. 

• If the customer or vendor record does exist in the Dynamics GP 
database, Maximizer creates a connection between the records. 

After you have linked an Address Book entry, you can create and 
view Dynamics GP invoices, quotes, and purchase orders from within 
Maximizer.

➤ To link an Address Book entry to Dynamics GP

� Open your Maximizer Address Book.

� Select the Company or Individual to link with Dynamics GP.

– or –

If the Company or Individual exists in Dynamics GP, but not in 
Maximizer, create a new Address Book entry in Maximizer.

� In Maximizer, click on the Accounting Link button on the toolbar 
to open the Accounting drop-down menu and select Link to 
Dynamics GP Customer/Vendor. 
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Alternatively, you can choose the command by right-clicking in 
the Accounting following window or from the Edit menu.

�You can expand your search by 
entering only the first few 
letters of the Company or 
Individual name in the Name 
field.

� Click Search to display a list of matching customers and/or 
vendors, if any. 

� If a matching entry appears in the list, select the entry and click 
OK to link the Address Book entry with the customer/vendor.

If you were able to complete this step, then skip the remainder 
of this procedure. The records are linked, and you can create 
purchase orders (vendors) or invoices and quotes (customers) for 
that Company or Individual.

�The OK button is disabled until 
you select a Dynamics GP 
record from the list of search 
results.

� If a matching entry does not appear in the list, click New.

The Add Accounting Customer/Vendor dialog box opens. 
Maximizer automatically fills in any existing contact information.
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� Select the Customer option to create the Address Book entry as 
a customer in Dynamics GP. (You can create invoices and quotes 
for customers.)

– or –

Select the Vendor option to create the Address Book entry as a 
vendor in Dynamics GP. (You can create purchase orders for 
vendors.)

�If you know the entry does not 
exist in your Company file, you 
can select the Create Dynamics 
GP Customer/Vendor from the 
Accounting menu in Maximizer 
while the Address Book entry 
is selected.

	 Enter a Cust/Vendor ID and Address ID such as you would in 
Dynamics GP and click OK. These identifiers are controlled 
manually in this dialog box. 

Maximizer and Dynamics GP now share a connection between 
these records.
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Creating Invoices, Quotes, and Purchase Orders
You can create invoices, quotes, and purchase orders in Maximizer, 
and they will automatically be created in Dynamics GP as well. Before 
you can create any of these transactions, the Company or Individual 
must be linked to either a customer or vendor record in Dynamics GP:

• To create an invoice or quote, the Address Book entry must be 
linked to a customer record.

• To create a purchase order, the Address Book entry must be 
linked to a vendor record.

You can also create new transactions based on existing transactions, 
and create invoices based on quotes. Maximizer copies the 
information from the original transaction into a new transaction and 
enables you to modify the new transaction before saving it. Details 
on these procedures are provided further along in this section.

Each time an invoice, a quote, or a purchase order is created or 
modified, a note is logged in Maximizer. 

➤ To create an invoice, quote, or purchase order

� In Maximizer, open the Address Book and select the Company 
or Individual to create a transaction for.

� Ensure that the Address Book entry is linked to the Dynamics GP 
database. If it isn’t, refer to “Linking Address Book Entries” on 
page 16 before proceeding with this procedure.
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�These menu items are also 
available from the shortcut 
menu and the Edit menu in the 
Accounting following window.

� Open the Accounting drop-down menu, and select Add 
Dynamics GP Invoice, Add Dynamics GP Quote, or Add 
Dynamics GP Purchase Order.

The Invoice, Quote, or Purchase Order dialog box opens. 
Maximizer automatically fills in the customer or vendor name 
and address, the date, and any tax information. Click on the 
arrow keys to view the details for information such as the tax.

�You cannot enter a value in the 
Invoice #, quote #, or P.O. 
Number field. When you click 
OK, the number is assigned 
automatically and the value is 
then read-only.

� In the Item column, click on New.
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�For detailed information about 
any of these fields, select the 
dialog box, and press F1.

� In the Add Item dialog box, select the Item name/number from 
the drop-down list.

� Add or change any of the other information in the Add Item 
dialog box, as required, and click OK.

� Repeat the last three steps until all required items have been 
added to the transaction.

	 Complete any remaining fields, as required, and click OK.

The transaction has now been created in both Maximizer and 
Dynamics GP, and Maximizer creates a history note in the Notes 
window of the Address Book. You can also view the invoice, 
quote, or purchase order from the Accounting tab of the 
Maximizer Address Book following window, as described on 
page 25.

Creating a New Transaction Based on an Existing One

Accounting Link enables you to create a new transaction (invoice, 
quote, or purchase order) based on an existing transaction, so the 
newly created transaction automatically contains the information 
from the original transaction, which you can then modify as 
required. This method saves you time because it reduces the amount 
of information you need to enter for similar transactions.

➤ To create a new transaction based on an existing 
transaction

� In Maximizer, open the Address Book and select the Company 
or Individual for whom to create an invoice, quote, or purchase 
order.

� Open the Accounting following window, and select the invoice, 
quote, or purchase order to use as the basis for the new 
transaction.
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�If the menu item is disabled, 
then you did not select a 
transaction in step 2. Select a 
transaction, and then create 
the new transaction.

Click the Accounting drop-down menu, and select Create New 
Dynamics GP Transaction from Selected.

– or –

Select Edit > Create New Dynamics GP Transaction from 
Selected.

– or –

Right-click in the Accounting following window, and select 
Add > Create New from Selected.

The Invoice, Quote, or Purchase Order dialog box opens, 
depending on the original transaction’s type. Maximizer 
automatically fills in all the information from the original 
transaction.

�You cannot enter a value in the 
Invoice #, Quote #, or P.O. 
Number field. When you click 
OK, the number is assigned 
automatically and the value is 
then read-only.

� Change any of the information in the transaction, or add more 
items to the list, as required. 

To remove an item, right-click on it and select Delete from the 
shortcut menu.

� Click OK.

The transaction has now been created in both Maximizer and 
Dynamics GP, and Maximizer creates a history note in the Notes 
window of the Address Book. You can also view the invoice, 
quote, or purchase order from the Accounting tab of the 
Maximizer Address Book following window, as described on 
page 24.

Creating an Invoice from a Quote

Accounting Link enables you to create a new invoice based on an 
existing quote, so the newly created invoice automatically contains 
the information from the original quote, which you can then modify 
as required. Making changes to the invoice does not apply those 
changes to the quote.

➤ To create a new invoice based on an existing quote

� In Maximizer, open the Address Book and select the Company 
or Individual for whom to create an invoice.

� Open the Accounting following window, and select the quote 
to use as the basis for the new transaction.
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�If the menu item is disabled, 
then you did not select an 
invoice in step 2, or the 
selected transaction is not a 
quote. Select a quote, and then 
create the new invoice.

� Click the Accounting drop-down menu, and select Create 
Invoice from Selected.

– or –

Select Edit > Create Invoice from Selected.

– or –

Right-click in the Accounting following window, and select 
Add > Create Invoice from Selected.

– or –

Open the quote and click the Invoice button.

The Invoice dialog box opens. Maximizer automatically fills in all 
the information from the original quote.

�You cannot enter a value in the 
Invoice # field. When you click 
OK, the number is assigned 
automatically and the value is 
then read-only.

� Change any of the information in the transaction, or add more 
items to the list, as required. 

To remove an item, right-click on it and select Delete from the 
shortcut menu.

� Click OK.

The invoice has now been created in both Maximizer and 
Dynamics GP, and Maximizer creates a history note in the Notes 
window of the Address Book. You can also view the invoice from 
the Accounting tab of the Maximizer Address Book following 
window, as described in the following section.
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Viewing Invoices, Quotes, and Purchase Orders
You can view existing invoices, quotes, and/or purchase orders for a 
customer or vendor from within Maximizer, even if the transaction 
was not created in Maximizer. When you link a Maximizer Address 
Book entry to a customer or vendor, existing invoices, quotes, or 
purchase orders display in Maximizer automatically. 

You can view existing transactions in the Accounting tab of the 
Maximizer Address Book following window.

➤ To view an invoice, quote, or purchase order

� In Maximizer, open the Address Book and select the Company or 
Individual for whom to view a transaction.

� Click the Accounting tab.

� Open the Filter drop-down list, and select Invoices, Quotes, 
Purchase Orders, or All Transactions

The transactions of that type for the selected customer or vendor 
appear. You can double-click any item to view the details.
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Viewing Accounting Details about a Customer or Vendor
Maximizer enables you to view the following accounting details 
about a customer or vendor from within Maximizer:

• customer balance

• aged analysis (30-, 60-, or 90-day balances)

• credit limit

• remaining available credit

➤ To view Dynamics GP accounting details

� In Maximizer, open the Address Book and select the Company or 
Individual for whom you want to view accounting details.

�This menu item is also 
available from the shortcut 
menu and the Edit menu in the 
Accounting following window.

� Open the Accounting drop-down menu, and select View 
Customer/Vendor Info.

The Customer/Vendor Information dialog box opens. It contains 
the accounting details for the selected Company or Individual.

� View the accounting details in the dialog box.

� You can click the Notes button to view or add additional 
information about the customer or vendor.
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� Click Close.
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